宝塔面板安装Flarum轻论坛程序时提示The PHP extension 'fileinfo' is required

原因

宝塔面板默认并没有安装fileinfo模块,可按以下教程安装:

注意:以下教程中56为PHP版本,请替换成您要安装此扩展的PHP版本,Flarum轻论坛程序最低要求PHP5.6+

解决过程

进入对应版本的fileinfo扩展源码目录

1
cd /www/server/php/56/src/ext/fileinfo

初始化扩展安装

1
/www/server/php/56/bin/phpize

生成编译配置

1
./configure --with-php-config=/www/server/php/56/bin/php-config

编译并安装扩展

1
make && make install

写入配置文件

1
echo 'extension=fileinfo.so' >> /www/server/php/56/etc/php.ini

重载PHP配置

1
service php-fpm-56 reload

这样就可以了。

您的支持将鼓励我继续创作!